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EXTREME INSTALLERS

Si

nan Karaca

nstallers are the first impression that end-users have
with your software, and as such are a very critical |
part of your application; however they are generally -
forgotten until the very last minute when managers
and developers alike are struck in panic, not sure
how to go about getting their installers done in time.
Fortunately, a wide variety of third party tools are available to help
with the task, and especially with Microsoft’s® introduction of
the Windows® Installer standard in 1999, building installers has
become a standardized process.

In this article we will explore Install Aware™, a fairly new instal-
lation development environment targeting Microsoft Windows
[nstaller. InstallAware has a couple of unique extras that help
especially with deploying NET Framework applications. Install-
Aware also makes it very easy to customize every aspect of the
end-user experience in the wizard dialogs, which we will be le-
veraging to create a custom dialog that captures user registration |
information, and posts it to a Web server, all as an integral part
of the main installation. !

.NET Framework Deployment ;
While deploying .NET applications is much easier compared
to traditional applications (no more DLL hell to suffer, thanks |

to assemblies), there are still some issues left over that merit
using an installer, as much as we would like to do plain XCOPY
deployment. The biggest of these is deployment of the .NET
Framework itself. Version 1.1 of the framework is a 23 MB down-
load; Version 2.0 is even larger at 26 MB. Especially considering
that our applications may be a lot smaller than that, typically
coming in at less than 1 MB for a rich client application, the

This article uses the following technologies:
Microsoft Windows Instal_ler,_Mi_c'r_osoft .NET, InstallAware Script

This article discusses:

+Reducing Size of the .NET Runtime

+ Partial Web Deployment of Application Runtimes

+Using InstalIAware'SCript and Dialog Designer for
Creating User

+ Feedback Forms During the (Un)Installation

Sinan Karaca was raised in diverse parts of the world. He went to primary school in Kabul.
Afghanistan, and received university education in Austin, Texas, where he degrees in Computer
Science and Philosophy. Sinan currently lives in Turkey, where he directs MimarSinan Inter-
national, a software company focusing on file and installation technologies for the Microsoft
Windows and recently .NET platforms. Sinan can be reached at sinank@mimarsinan.com.
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burden of the runtime becomes
especially apparent.
InstallAware helps us with
that, in a couple of unique ways.
The first is to reduce the size of
the runtime itself. InstallAware
utilizes a form of lossless com-
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21 Web Media Blocks control how your setup is packaged into parts
=1 thatare dynamically downloaded from the web at run-time, Place
related features of your install into the same block. This way, your
users have minimal overhead while downloading. Actions which
require source media (such as file installation) will download the
entare mﬁd?a block ﬁl&?’ are c&ntam&cé in b&fﬂm ﬂw&‘? &:{mﬁ&
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flesh out your product installation

first. Then, click the Build Settings

button under the Deployment

heading, and notice InstallAware

offers three build types:

» Uncompressed Directory Lay-
out: Best for installers distrib-
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pression that exceeds the com- "f{?ﬁ‘ﬁ&ﬁaﬁiﬁﬁiﬁ% @’?ﬁ“ﬁ?ﬁ”‘fﬁ?’}i@i@i@ . | uted on CD/DVD media, where
pression used in the standard | DNETRWIN mewwwi space is not usually a limiting
NET Framework installer. This | Download URL: - | factor. Install Aware builds your
compression algorithm is so ef- | [os/fmnstslonsre.confoetnzsp | | setup using multiple folder and
ficient that it reduces the NET | o0 o Bulld (el when o oo i Tk o b file structures.
Framework installer down to 12 e ———— |« Compressed Single Self Install-
MB, and compared to the already s LD ing EXE: InstallAware builds a
e — a1 single self-installing executable

compressed size of 23 MB, that is
almost 50% savings!

tgure 1 Defining a Web Medla Block

file. This is similar to the mono-

It you have not done so already, visit www.installaware.com and = lithic installers that contain all application files and runtimes ina
download Install Aware Studio first. Then, open the InstallAware  single package that works without requiring an Internetconnec-

IDE, and choose File->New-> .NET Script to start a new NET tion.

Framework installer project. InstallAware features visual editors =« Compressed Web Based EXE: Install Aware builds a self-install-
that you can use to rapidly specify the files, registry entries, short- =~ ing EXE, and strips away runtimes (along with other optional
cuts, assemblies, and any other items that comprise your applica- =~ application features) into other files downloadable from the
tion. These views work similarly in most installer environments, Internet on-the-fly during an installation.

so we won't cover them here: but feel free to make use of them to

Choose the Compressed Single Self Installing EXE option,

and build your setup by choosing

& My dothET Script - InstallAWARE i Project->Build. If you build an empty
1 : . -1 .
i File Edit Yiew Project Run Tools Hﬁiﬂ‘ - . | project this way, the resulting install-
fued PaBX €8 ! b e FRO o BLI% oo Ei‘jf?ff _..» % | erfilewill be approximately 15 MB in
| Commands: ' Iﬁﬁtﬁ%@aﬁaﬂ b | | - | |
{advertised e Type.. ia] 2 | f’m " gl size. Notice that this file already 111 -
i ﬁ"d‘ ﬁ éSh i t W-MT % o T 5 & Al el Tl e e e e E T
ooy Changes | | ° /S M Mo S5ES5S  IIIIIX Il cludes the NET Framework, and the
; a3 L S MM MM OSE Ir i _ ,
| Check Fie version |¢ | // MMMM ssssss II I Windows Installer runtime—along
‘éﬁiﬁiﬁmﬁ fse | 7 i S R o el * with our setup MSI files! We can
| Compiler Variable £nd o - T MeNMRAE Sosass >
| 17 /) i already see InstallAware’s great com-
| Compiler Variable If f ? - | i Y g
| Control TIS Site = " 4 Project Rame: $£355 . : :
| | Control Service | % @ v Description: InstailaFaARE Instzilation Script E pI'EESSlOIl at WOI’k here—typlcally the
gz;;*?g;’z?ﬂ — % 0 /7 Comments: .NET Zpplication Template Script E size of both runtimes weighg in quite
£ i :
gz:z: ;i?dz?ﬂ %E £ // Check system has at least Windows 38 E heawly at 26 MB.
! Create IS Site g E i3 Get Systen Setting Windows 288 into CHECKCS g B
Create ODBC DEN g % i4 3 if Variable CHECKOS not Eguals TRUE ; BUt A 0 d.O better than that by
| Create Share =115 | MessageBox: STITLES Setup Errox, This product cannot be inst i isolating both these runtimes from
i Create Shorteut a | ;
|Create Vil Foider | 7% | Terminate Installacion | our main installer, and putting them
| Define Component P 27 en i
| Delete Files |18 | onthe Web for download on demand
De}at&ﬁﬁﬁst& |15 / Check system has 2t least Internst Explorer 5.01 Service P J * j
nggi gﬁﬁiw |20 | Get System Setting Internet Explorer 5.01 Service Pack 1 into * using Web deployment. Web dePIOY'
P e : S CHECKIE 1 i .
|Delete VirtualFolder | 2= | If Variable CHECKIE not Equals TRUE | I ment does have the downside that
i Display Dialog | 22 MezsageBox: $TITLES 3Jetup Error, This product reguires Inte: i ‘
Does FefFolder Exist | 23 Terminate Installacion | everything goes on the Web—even
1 24 | end L . .
| . | I our essential application files, thus
| Extract Path 2% | // Check setup pre-requisites mandating an Internet connection ev-
| Generate Native Images £ 27 i Set Varisble PRERE(D to FALSE | . . .
gzg E;ZE;’;‘L”HT;‘; tState 22 | Set Variable PRELIST to | erytime the install is run. Fortunately -
| Get File Version £28 1 Set Variable HINST20 o TRUE | InstallAware offers a unique partial
{;EtFﬁgder | ocation { 30 Set Varizsble DOTNETLIZI to TRUE | _
G&tHSPrﬂperty | 32 icompiler if Variable BUILDMODE not Eguals PATCH) i WEb deployment OpthIl thﬁt TCINOVES
i Get IIS Site Index rd 2 | ot fTear a3 WMindnes Tonenllom debhacd  ees sasesde dnes sresisoiGall : . . s : :
@et;@sz}fge@mmrj weewe ) —~— 0020 this limitation on Web deployed in-
- Variable Name o | valee stallers.
|
mmﬁi e —— e e Partial Web Deployment
e, & ’"“:5"“‘.”"'- . s .

Figure 2 The InstallAware Script
32 msdnmagazine .NET Runtime

Now build the same setup using the
Compressed Web-Based EXE option,




which will build our setup for partial Web deployment on the

Web. After the build is complete, choose File->Open Build Folder

and explore the output:

e setup.exe: This is the main installation file, and contains your
essential application files, along with the setup MSI files. Note
that this file may be named differently based on the name you
chose for your setup project.

e DNETRUN.7zip: This is the NET Framework partial Web de-
ployment file, called a Web media block in Install Aware. Notice

the size—KB—almost half the regular size of the runtime, at only

12.1 MB.
» MSIRUN.7zip: This is the Windows Installer runtime, and again,
weighs in at half the regular size, at 1.83 MB.

While setup.exe is running, if all the runtimes are already

installed on the target system, it will not connect to the Internet

to download anything, as essential application files are already

inside the setup.exe. This is what partial Web deployment offers
over and above traditional Web deployment schemes, which
force you to put even your vital application files on the Internet,

needlessly requiring an Internet connection after you have already

downloaded your setup once already.
If some of the runtimes are required, setup will first try to

find the Web media block files in the same folder as itself. If

they are found there, it will use them from that location to
prevent connecting to the Internet. If they are not found, it
will connect to the Internet, and download them automatically,
as a seamless part of the main installation. If the download
is interrupted (or corrupted) for any reason, all we have to
do is try again—setup.exe will resume from where it left off,

and not re-download the entire file. The process is also proxy

friendly—it will automatically detect proxy server configura-
tion on the target system.

The setup engine that Install Aware uses is Internet Explorer’s®
native download engine. InstallAware supports installations
on every version of Windows—from theWindows 95° Gold
release to the latest Windows Server 2003 system, so Inter-

net Explorer may not be pre-installed on earlier versions of

Windows (Windows 95 and Windows NT® 4.0 in particular),
however in that case Install Aware will fall back to its second-
ary, native download engine to make sure your installs succeed
without a hiccup.

But how does our setup know where it is to obtain the Web
media block files from? Click the Web Media Blocks button under

the Deployment heading. You will see a list of Web media block
files, including DNETRUN and MSIRUN. Double-click one of

these, and the Define Web Media Block dialog opens, wich is
shown in Figure 1.

The Web Media Block Name field determines the name of the
Web media block file that is created during the build process.
The Download URL field tells the setup program where it can

download the Web media block file from at runtime. All you need

to do is upload your Web media block file to a Web server, and
type in the download URL for that location in here. The rest is all
automatic, and there are no specific server requirements for Web
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deployment. Just publish the Web media block file asan ordinary | InstallAware also lets you use the Web media block mechanism
file to the location described in the Download URL field. ' to precisely split your setup into any number of online and offline
You can also enter non-Internet locations in the Down- parts. For instance, you could put rarely used or bulky applica-
load URL field, such tion parts, such as clip-art collections for word processors, inside
as a corporate net- their own Web media blocks, and separate them from the main
work share of the form setup. We can precisely control what parts of our application go
\\server\share\path\ = where—and to do that we will switch to the code view.
Weblock.7zip. This has
the additional side ef- The Code View
fect of protecting your Choose View->Code to switch to the Install Aware Script view.
installers from running = What we see is a conditionally flowing, traditional setup script;
at off-site locations, = with commands like Install Files, Create Shortcut, and the like.
since the installer will = Feel free to take a quick look at script (or print it for a hardcopy
never find a file that resides inside your corporate network while | reference) to get a sense for how the setup logic flows. Of course,

you are not physically connected to the network. - you can change everything—the script we're looking at is just
the template script that the IDE created for us when we

S started our new project (see Figure 2 for the script).

i'mmm.;-f;; P e e ﬂ;;wmf”ﬁhﬁﬁ %ﬁﬁﬂﬁmiﬁﬁaﬂﬁf@ Efm

Bdt Vew Took tep Whenever you make changes in the visual view, as
we had been doing so far, the IDE updates the underly-

ing script for us automatically. Likewise, after making

. changesin the code view, if we switch back to the visual
S view, the visual view updates itself accordingly, making
1 RAD setup development possible. The code view is
= the heart of the installation and contains all the com-
- ? g DRI mands that drive our setup, and of course, at build time,
ociniiiiiconso i the InstallAware Script code is compiled into a logo
= m = N ooinmiiniiiiiid compliant MSI database, capable of running directly
i?; g-'?e} '_ = o | withoutre quiring a third party scripting engine on the
= e d S TypeCTRL+Fandsearch for Define Web Media. The

R T R e EO T Sy S U e S L e s e g T L e S S R

o an i editor highlights the Web media blocks that have been

 defined in the script, including DNETRUN and MSI-
RUN. The script can contain any number of Web Media
Block statements. To define a new Web media block,
simply double-click the Web Media Block command
from the list of commands listed on the left of your

------------------------------

i Object Behaviors determine what setup contents dialog controls are assodated with (such as a tree view ] SEtup SC‘I'IP L wa Define Web Media Block (?'Ialog we
| | dapiaying your }mmnmt hierarchy), and the effects dicking certain controls has (such as moving forward in | osaw earlier in the visual view opens. Every subsequent
wizard loop - | _
| Receives Information: _ - installation command (such as Install Files) that follows
g > <none> %] (setup data dispiayedby the contre) | | the Web media block statement will put its contents
B  inside the named Web media block, until you define
| | Control: | Writes Values to Variable: . : :

B o ] _}f““““g{}ggéggr ““““““““““““ ] i ] another Web media block in your ScCript.

| lUseEme? ] 7 [EMALADDRESSI | ({scriptvariables set to control values) | | .

B | Ifyouleave the Web block name emptyin the Define
| e Ao |  Web Media Block dialog, and click OK to return to the
e -~ (changing dizlogs, starting setup) || script, InstallAware inserts the command OFFLINE
| | Tip: You can use vaﬁahiceﬂ ;n éﬁ;i;ﬁ control properties, ﬁiﬁaeymaﬁfm&imﬁgm;; to their vaii.aesatﬁ % CONTENT into your SCI‘lp’[ If you search for OFF-
‘ runtime, For instance, ifala caption STITLES, the label will display the value of the TITLE variable rom | |

| | the scriptasits caption. | LINE CONTENT, you will also find the initial one that
| | was already inserted for us when we first started the
e | project. Files that follow the offline content directive
| | are placed directly inside the setup.exe file, so if you
| | have parts of your application that are always to be
| — : = = | installed, placing them after an offline content state-
- @ @ @ @@ @@ @ A ment ensures that they will always be available with
Fagm’e 4 A531gmng Scrtpt Variables to Dia!og Controls the main setup.exe file,

34 msdnmagazine .NET Runtime



Using the Web Media Block commands, you can
precisely craft your setups into any number of offline
and online parts. You can even share Web media
blocks across different setups, as long as they contain
shared files. The script editor gives us full freedom in
deciding what goes where.

Ll P bt

o LNl

Posting User Information

Let's now explore the InstallAware Dialog Editor
(see Figure 3), and capture user information which we
will post during the install to a Web server. First switch
back to the visual view by choosing View->Visual, and
then click the Dialogs button under the User Interface heading.
From the Dialog Sequence listing double-click the registration
dialog which we will be customizing to capture an e-mail address,
in addition to the name and company of the user.

The dialog editor opens with the default registration dialog. We
have an object properties window that we can use to customize
our dialog properties, along with a rich component palette, includ-
ing HTML and Flash containers that can be used for interactive
billboards during an installation. For now, place a text label and
an edit control on the form. Edit the Caption property of the text
label to read &Email Address, and edit the Text property of the edit
control to leave it blank. Set the Name property of the edit control

to UserEmail and remember to set the FocusControl property of

the text label to UserEmail, so users can use keyboard shortcuts
if necessary. We also want to make registration optional, so users
are submitting information only if they want to. Add a check-
box to the form, set its Name property to RegisterMe, Caption to
&Register on the Internet, and Checked to TRUE.

Now its time to link these controls with our setup script.
Double-click the edit control to show the Define Interactive
Characteristics dialog, and choose the Object Behavior tab, as
you can see in Figure 4.

Enter EMAILADDRESS in the Write Values to Variable field.
This way, we will be able to access the text entered by the user into
our edit control from our InstallAware Script by referencing the
EMAILADDRESS script variable. Then click the Control drop-
down box and choose RegisterMe. Tell this control to write to the
variable SUBMITONLINE.

You may also choose the Name and Company controls from
the Control drop-down to see that the dialog is already config-
ured to write the user name and user company information into
the USERNAME and USERCOMPANY variables respectively.
Click Close, the choose File->Save to save the changes we made
to our dialog. Remember that you can always customize the ap-
pearance of the dialog later by playing with the Object Properties
window.

Now switch back to the Code view in the main InstallAware
IDE, see Figure 5. Scroll to the top of the script, and insert a Set
Variable command to set the default value of the EMAILAD-
DRESS variable to an empty string, and insert another Set Vari-
able command to set the default value of the SUBMITONLINE
variable to TRUE.

- Instaﬁaﬁm Smpt
Set

Set

Variable EMAILADDRESS
Variable SUBMITONLINE v TRIUE

Lo

P ey ey ey ey gy W By el Al ol ek

i ik | e i i Eai® P dinal A A

P XM L2 Iz instailiFARE 2008 for ¥indovs

E’E M M M S5E5E8ES iz Copyrigntic} 1596-Z00F Instzl
M M =5 L .4 A1l rights reserved

Flgure 5 Initia l[zmg Scrzpt Vaﬂables

Now type CTRL+F and search for the text Apply Install. We

-~ will use custom scripting to submit the user information right
- before processing the installation. First insert an [F command to

test the value of the SUBMITONLINE variable, so we respect the
~end-user’s wish on submitting their personal information (see

Figure 6). The &Register on the Internet check-box in the registra-

tion dialog will write Boolean values to this variable depending

on user selection at run-time.

Next, insert a Download File command after the if Variable
SUBMITONLINE Equals TRUE statement. If you cannot find

the Download File command, just scroll to the bottom of the

e L L —_ T mrm—
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commands list, which is
where plug-in provided
commands are displayed
(InstallAware is plug-in
extensible, and posting to
Web servers is provided
by the Download File
plug-in). In the URL field,
enter the location of the
Web server to post user
information to, using a
form like: www.mimarsinan.
com/postuser.asp?name=$USER
NAMES&company=$USERCOMPANY
$&email=$EMAILADDRESSS.
Notice that variables
are dereferenced in Install-
Aware Script by enclosing

them with dollar signs. If

you have a variable called
VAR, using $VARS in
your script dereferences
the value of that variable.

Populate the remainder of

the fields in the Download
File command as you
deem appropriate, such as
in the figure below.

In the Figure 7, we used
the pre-defined script
variable $TEMPDIRS$ to
hold the returning file

im0 Bt 5 RO N s
261 | if Variable SUBMITONLINE Equals TRUE
262 Download File noop://www.mimarsinan,com/postuser.aspnane=SUSERNAMES scor
| 1263 | end "
éaﬂé hpply Install {gEt result into varisble SE“C“SS}

R R i s L B S e

Figure 8 Script Commands for Postmg User Information

~ from the post operation. Install Aware Script pre-defines other
-~ useful variables that you may use in your script, to see a full list,
 just search for Pre-Defined Variables in the help index. Also note
~ that we didn’t have to do anything extra to obtain the value of
~ the new edit control we popped on the registration dialog—just
 referencing the variable is enough.

Finally drag-drop an End command from the commands list
after the Download File statement, so we're closing our conditional

IF block, see Figure 8.

With the custom script commands in place, we're good to go.

Let's build and test our setup. Choose Project->Options, and then
- select

Uncompressed Directory Layout under the Build node (we
don’t want to spend time compressing while we're still developing
and testing our setup). Click OK, and then choose Project->Build
to make the setup. Finally, choose Run->Run Without Debugging

 to see our setup in action. Of course, if you want to step through
~ the setup line by line, you can choose Run->Step, or set break-
~ points and choose Run->Run for debugging.

Conclusion
With partial Web deployment and powerful scripting, Install-

~ Aware provides a great way to deploy .NET Framework applica-
 tions. The visual views assist in rapidly prototyping your setup, and
 the code view lets you fine tune existing behavior, such as we did
for submitting custom user information. Let your creativity soar
with the dialog designer and the script view—making intelligent
 installers that provide a lasting first impression is now quick and
~ enjoyable. =
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