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Altera® and strategic IP partners offer a broad portfolio of off-the-shelf, configurable IP cores optimized for
Altera devices. The Altera Complete Design Suite (ACDS) installation includes the Altera IP library. The
OpenCore and OpenCore Plus IP evaluation features enable fast acquisition, evaluation, and hardware
testing of Altera IP cores.

You can integrate optimized and verified IP cores into your design to shorten design cycles and maximize
performance. The Quartus® II software also supports IP cores from other sources. Use the IP Catalog to
efficiently parameterize and generate a custom IP variation for instantiation in your design.

The Altera IP library includes the following IP core types:

• Basic functions
• DSP functions
• Interface protocols
• Memory interfaces and controllers
• Processors and peripherals

The IPCatalog (Tools> IPCatalog) and parameter editor replace theMegaWizard™Plug-InManager
for IP selection and parameterization, beginning in Quartus II software version 14.0. Use the IP
Catalog and parameter editor to locate and paramaterize Altera and other supported IP cores.

Note:

Related Information

• IP User Guide Documentation

• Altera IP Release Notes

Installing and Licensing IP Cores
The Altera IP Library provides many useful IP core functions for production use without purchasing an
additional license. You can evaluate any Altera IP core in simulation and compilation in the Quartus II
software using theOpenCore evaluation feature. SomeAltera IP cores, such asMegaCore® functions, require
that you purchase a separate license for production use. You can use the OpenCore Plus feature to evaluate
IP that requires purchase of an additional license until you are satisfiedwith the functionality and performance.
After you purchase a license, visit the Self Service Licensing Center to obtain a license number for any Altera
product.
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Figure 1: IP Core Installation Path

acds
quartus - Contains the Quartus II software
ip - Contains the Altera IP Library and third-party IP cores

altera - Contains the Altera IP Library source code
<IP core name> - Contains the IP core source files

The default IP installation directory on Windows is <drive>:\altera\<version number>; on Linux it
is <home directory>/altera/ <version number>.

Note:

Related Information

• Adding IP Cores to IP Catalog on page 4

• Altera Licensing Site

• Altera Software Installation and Licensing Manual

OpenCore Plus IP Evaluation
Altera's free OpenCore Plus feature allows you to evaluate licensed MegaCore IP cores in simulation and
hardware before purchase. You need only purchase a license for MegaCore IP cores if you decide to take
your design to production. OpenCore Plus supports the following evaluations:

• Simulate the behavior of a licensed IP core in your system.
• Verify the functionality, size, and speed of the IP core quickly and easily.
• Generate time-limited device programming files for designs that include IP cores.
• Program a device with your IP core and verify your design in hardware

OpenCore Plus evaluation supports the following two operation modes:

• Untethered—run the design containing the licensed IP for a limited time.
• Tethered—run the design containing the licensed IP for a longer time or indefinitely. This requires a

connection between your board and the host computer.

All IP cores that use OpenCore Plus time out simultaneously when any IP core in the design times
out.

Note:

IP Catalog and Parameter Editor (replaces MegaWizard Plug-In Manager)
TheQuartus II IP Catalog (Tools > IPCatalog) and parameter editor help you easily customize and integrate
IP cores into your project. You can use the IP Catalog and parameter editor to select, customize, and generate
files representing your custom IP variation.

The IPCatalog (Tools> IPCatalog) and parameter editor replace theMegaWizard™Plug-InManager
for IP selection and parameterization, beginning in Quartus II software version 14.0. Use the IP
Catalog and parameter editor to locate and paramaterize Altera IP cores.

Note:
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The IP Catalog lists IP cores available for your design. Double-click any IP core to launch the parameter
editor and generate files representing your IP variation. The parameter editor prompts you to specify an IP
variation name, optional ports, and output file generation options. The parameter editor generates a top-
level Qsys system file (.qsys) or Quartus II IP file (.qip) representing the IP core in your project. You can
also parameterize an IP variation without an open project.

Use the following features to help you quickly locate and select an IP core:

• Filter IP Catalog to Show IP for active device family or Show IP for all device families.
• Search to locate any full or partial IP core name in IP Catalog. Click Search for Partner IP, to access

partner IP information on the Altera website.
• Right-click an IP core name in IP Catalog to display details about supported devices, open the IP core's

installation folder, andor view links to documentation.

Figure 2: Quartus II IP Catalog

Search and filter IP for your target device

Double-click to customize, right-click for information

The IP Catalog is also available in Qsys (View > IP Catalog). The Qsys IP Catalog includes exclusive
system interconnect, video and image processing, and other system-level IP that are not available in

Note:

the Quartus II IP Catalog. For more information about using the Qsys IP Catalog, refer to Creating
a System with Qsys in the Quartus II Handbook.

Related Information

• Creating a System with Qsys
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Using the Parameter Editor
The parameter editor helps you to configure IP core ports, parameters, and output file generation options.

• Use preset settings in the parameter editor (where provided) to instantly apply preset parameter values
for specific applications.

• View port and parameter descriptions, and links to documentation.
• Generate testbench systems or example designs (where provided).

Figure 3: IP Parameter Editors

View IP port
and parameter
details

Apply preset parameters for
specific applications

Specify your IP variation name
and target device

Legacy parameter
editors

Adding IP Cores to IP Catalog
The IP Catalog automatically displays Altera IP cores found in the project directory, in the Altera installation
directory, and in the defined IP search path. The IP Catalog can include Altera-provided IP components,
third-party IP components, custom IP components that you provide, and previously generatedQsys systems.

You can use the IP SearchPath option (Tools >Options) to include custom and third-party IP components
in the IP Catalog. The IP Catalog displays all IP cores in the IP search path. The Quartus II software searches
the directories listed in the IP search path for the following IP core files:

• Component Description File (_hw.tcl)—Defines a single IP core.
• IP Index File (.ipx)—Each .ipx file indexes a collection of available IP cores, or a reference to other

directories to search. In general, .ipx files facilitate faster searches.

The Quartus II software searches some directories recursively and other directories only to a specific depth.
When the search is recursive, the search stops at any directory that contains an _hw.tcl or .ipx file.

In the following list of search locations, a recursive descent is annotated by **. A single * signifies any file.

Table 1: IP Search Locations

DescriptionLocation

Finds IP components and index files in the Quartus II project directory.PROJECT_DIR/*
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DescriptionLocation

Finds IP components and index files in any subdirectory of the /ip
subdirectory of the Quartus project directory.

PROJECT_DIR/ip/**/*

Figure 4: Specifying IP Search Locations

Adds new global IP search paths

Changes search path order

Adds new project-specific IP search paths

Lists current project and global search paths

If the Quartus II software recognizes two IP cores with the same name, the following search path precedence
rules determine the resolution of files:

1. Project directory.
2. Project database directory.
3. Project IP search path specified in IP Search Locations, or with the SEARCH_PATH assignment in the

Quartus II Settings File ( .qsf) for the current project revision.
4. Global IP search path specified in IP Search Locations, or with the SEARCH_PATH assignment in the

quartus2.ini file.
5. Quartus II software libraries directory, such as <Quartus II Installation>\libraries.

If you add a component to the search path, you must refresh your system by clicking File > Refresh
to update the IP Catalog.

Note:

General IP Core Settings
You can use the following settings to control how the Quartus II software manages IP cores in your project.
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Table 2: IP Core General Setting Locations

DescriptionSetting Location

• Specify your IPgenerationHDLpreference. The parameter editor generates
IP files in your preferred HDL by default.

• Increase Maximum Qsys memory usage size if you experience slow
processing for large systems, or if Qsys reports an Out of Memory error.

Tools > Options > IP
Settings

Or

Assignments > Settings >
IP Settings (only enabled
with open project)

• Specify project and global IP search locations. The Quartus II software
searches for IP cores in the project directory, in the Altera installation
directory, and in the IP search path.

Tools > Options > IP
Catalog Search Locations

Or

Assignments > Settings >
IPCatalogSearchLocations

• NativeLink Settings allow you to automatically compile testbenches for
supported simulators. You can also specify a script to compile the testbench,
and a script to set up the simulation.

Assignments > Settings >
Simulation

Specifying IP Core Parameters and Options
The parameter editor GUI allows you to quickly configure your custom IP variation. Use the following steps
to specify IP core options and parameters in the Quartus II software. Refer to Specifying IP Core Parameters
and Options (Legacy Parameter Editors) for configuration of IP cores using the legacy parameter editor.

1. In the IP Catalog (Tools > IP Catalog), locate and double-click the name of the IP core to customize.
The parameter editor appears.

2. Specify a top-level name for your custom IP variation. The parameter editor saves the IP variation settings
in a file named <your_ip>.qsys. Click OK.

3. Specify the parameters and options for your IP variation in the parameter editor, including one or more
of the following. Refer to your IP core user guide for information about specific IP core parameters.

• Optionally select preset parameter values if provided for your IP core. Presets specify initial parameter
values for specific applications.

• Specify parameters defining the IP core functionality, port configurations, and device-specific features.
• Specify options for processing the IP core files in other EDA tools.

4. Click Generate HDL, the Generation dialog box appears.
5. Specify output file generation options, and then clickGenerate. The IP variation files generate according

to your specifications.
6. To generate a simulation testbench, click Generate > Generate Testbench System.
7. To generate an HDL instantiation template that you can copy and paste into your text editor, click

Generate > HDL Example.
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8. Click Finish. The parameter editor adds the top-level .qsys file to the current project automatically. If
you are prompted to manually add the .qsys file to the project, click Project > Add/Remove Files in
Project to add the file.

9. After generating and instantiating your IP variation, make appropriate pin assignments to connect ports.

Figure 5: IP Parameter Editor

View IP port
and parameter
details

Apply preset parameters for
specific applications

Specify your IP variation name
and target device

Related Information
Specifying IP Core Parameters and Options (Legacy Parameter Editors) on page 11

Files Generated for Altera IP Cores
The Quartus II software version 14.0a10 and later generates the following IP core output file structure when
targeting Arria 10 devices.
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Figure 6: IP Core Generated Files

<your_testbench>_tb.csv

<your_testbench>_tb.spd

<your_ip>.cmp - VHDL component declaration file

<your_ip>.ppf - XML I/O pin information file

<your_ip>.qip - Lists IP synthesis files

<your_ip>.sip - Lists files for simulation

<your_ip>.v or .vhd
Top-level IP synthesis file

<your_ip>.v or .vhd
Top-level simulation file

<simulator_setup_scripts>

<your_ip>.qsys - System or IP integration file

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file

<your_ip>_inst.v or .vhd - Sample instantiation template

<your_ip>_generation.rpt - IP generation report

<your_ip>.debuginfo - Contains post-generation information
<your_ip>.html - Connection and memory map data

<your_ip>.bsf - Block symbol schematic
<your_ip>.spd - Combines individual simulation scripts

<your_ip>_tb.qsys
Testbench system file

<your_ip>.sopcinfo - Software tool-chain integration file

<project directory>

<EDA tool setup
scripts>

<your_ip>

IP variation files
<testbench>_tb

testbench system

sim

Simulation files

synth

IP synthesis files

sim
simulation files

<EDA tool name>
Simulator scripts

<testbench>_tb

<ip subcores> n
Subcore libraries

sim
Subcore

Simulation files

synth
Subcore

synthesis files

<HDL files><HDL files>

<your_ip> n

IP variation files

testbench files

Table 3: IP Core Generated Files (version 14.0a10)

DescriptionFile Name

TheQsys system or top-level IP variation file. <my_ip> is the name that
you give your IP variation.

<my_ip>.qsys

Describes the connections and IP component parameterizations in your
Qsys system. You can parse its contents to get requirements when you
develop software drivers for IP components.

Downstream tools such as the Nios II tool chain use this file. The
.sopcinfo file and the system.h file generated for the Nios II tool chain
include address map information for each slave relative to each master
that accesses the slave. Different masters may have a different address
map to access a particular slave component.

<system>.sopcinfo
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DescriptionFile Name

TheVHDLComponentDeclaration (.cmp) file is a text file that contains
local generic and port definitions that you can use in VHDL design
files.

<my_ip>.cmp

A report that contains connection information, amemorymap showing
the address of each slave with respect to each master to which it is
connected, and parameter assignments.

<my_ip>.html

IP or Qsys generation log file. A summary of the messages during IP
generation.

<my_ip>_generation.rpt

Contains post-generation information. Used to pass System Console
and Bus Analyzer Toolkit information about the Qsys interconnect.
The Bus Analysis Toolkit uses this file to identify debug components
in the Qsys interconnect.

<my_ip>.debuginfo

Contains all the required information about the IP component to
integrate and compile the IP component in the Quartus II software.

<my_ip>.qip

Contains information about the upgrade status of the IP component.<my_ip>.csv

A Block Symbol File (.bsf) representation of the IP variation for use in
Quartus II Block Diagram Files (.bdf).

<my_ip>.bsf

Required input file for ip-make-simscript to generate simulation
scripts for supported simulators. The .spd file contains a list of files
generated for simulation, along with information about memories that
you can initialize.

<my_ip>.spd

The Pin Planner File (.ppf) stores the port and node assignments for
IP components created for use with the Pin Planner.

<my_ip>.ppf

You can use the Verilog black-box (_bb.v) file as an empty module
declaration for use as a black box.

<my_ip>_bb.v

Contains information required for NativeLink simulation of IP
components. You must add the .sip file to your Quartus II project.

<my_ip>.sip

HDL example instantiation template. You can copy and paste the
contents of this file into your HDL file to instantiate the IP variation.

<my_ip>_inst.v or _inst.vhd

If IP contains register information, .regmap file generates. The .regmap
file describes the registermap information ofmaster and slave interfaces.
This file complements the .sopcinfo file by providing more detailed
register information about the system. This enables register display
views and user customizable statistics in the System Console.

<my_ip>.regmap

AllowsHPS SystemDebug tools to view the registermaps of peripherals
connected to HPS within a Qsys system.

During synthesis, the .svd files for slave interfaces visible to System
Console masters are stored in the .sof file in the debug section. System
Console reads this section, which Qsys can query for register map
information. For system slaves, Qsys can access the registers by name.

<my_ip>.svd
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DescriptionFile Name

HDL files that instantiate each submodule or child IP core for synthesis
or simulation.

<my_ip>.v

or

<my_ip>.vhd

Contains a ModelSim® script msim_setup.tcl to set up and run a
simulation.

mentor/

Contains a Riviera-PRO script rivierapro_setup.tcl to setup and run a
simulation.

aldec/

Contains a shell script vcs_setup.sh to set up and run aVCS® simulation.

Contains a shell script vcsmx_setup.sh and synopsys_ sim.setup file to
set up and run a VCS MX® simulation.

/synopsys/vcs

/synopsys/vcsmx

Contains a shell script ncsim_setup.sh and other setup files to set up and
run an NCSIM simulation.

/cadence

Contains HDL files for the IP core submodule./submodules

For each generated child IP core directory, Qsys generates /synth and
/sim sub-directories.

<child IP cores>/
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Specifying IP Core Parameters and Options (Legacy Parameter Editors)
The Quartus II software version 14.0 and previous uses a legacy version of the parameter editor for IP core
configuration and generation. Use the following steps to configure and generate an IP variation using a
legacy parameter editor.

The legacy parameter editor generates a different output file structure than the latest parameter
editor. Refer to Specifying IP Core Parameters andOptions for configuration of IP cores in theQuartus
II software version 14.0a10 and later.

Figure 7: Legacy Parameter Editors

Legacy parameter
editors

Note:

1. In the IP Catalog (Tools > IP Catalog), locate and double-click the name of the IP core to customize.
The parameter editor appears.

2. Specify a top-level name and output HDL file type for your IP variation. This name identifies the IP core
variation files in your project. Click OK.

3. Specify the parameters and options for your IP variation in the parameter editor. Refer to your IP core
user guide for information about specific IP core parameters.

4. Click Finish or Generate (depending on the parameter editor version). The parameter editor generates
the files for your IP variation according to your specifications. Click Exit if prompted when generation
is complete. The parameter editor adds the top-level .qip file to the current project automatically.

Tomanually add an IP variation generatedwith legacy parameter editor to a project, clickProject>
Add/Remove Files in Project and add the IP variation .qip file.

Note:

Related Information
Specifying IP Core Parameters and Options on page 6
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Files Generated for Altera IP Cores (Legacy Parameter Editors)
The Quartus II software version 14.0 and previous generates one of the following output file structures for
Altera IP cores.

Figure 8: IP Core Generated Files (Legacy Parameter Editor)

Generated IP File Output C Generated IP File Output D

Generated IP File Output B
<Project Directory>

<your_ip>.html - IP core generation report

<your_ip>_testbench.v or .vhd - Testbench file1

<your_ip>.bsf - Block symbol schematic file

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist1
<your_ip>_bb - Verilog HDL black box EDA synthesis file

<your_ip>.vo or .vho - IP functional simulation model 2

<your_ip>.qip - Quartus II IP integration file
<your_ip>.v or .vhd - Top-level HDL IP variation definition

<your_ip>_block_period_stim.txt - Testbench simulation data 1

<your_ip>-library - Contains IP subcomponent synthesis libraries

Generated IP File Output A
<Project Directory>

<your_ip>.v or .vhd - Top-level IP synthesis file

<your_ip>_inst.v or .vhd - Sample instantiation template

<your_ip>.bsf - Block symbol schematic file

<your_ip>.vo or .vho - IP functional simulation model 2
<your_ip>_syn.v or .vhd - Timing & resource estimation netlist1

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file

<your_ip>.qip - Quartus II IP integration file

greybox_tmp 3
<your_ip>.cmp - VHDL component declaration file

<Project Directory>

<your_ip>_sim 1

<Altera IP>_instance.vo - IPFS model 2

<simulator_vendor>
<simulator setup scripts>

<your_ip>.qip - Quartus II IP integration file

<your_ip>.sip - Lists files for simulation

<your_ip>_testbench or _example - Testbench or example1

<your_ip>.v, .sv. or .vhd - Top-level IP synthesis file

<Altera IP_name>_instance

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist1
<your_ip>.cmp - VHDL component declaration file
<your_ip>.bsf - Block symbol schematic file

<your_ip> - IP core synthesis files
<your_ip>.sv, .v, or .vhd - HDL synthesis files
<your_ip>.sdc - Timing constraints file

<your_ip>.ppf - XML I/O pin information file
<your_ip>.spd - Combines individual simulation scripts 1

<your_ip>_sim.f - Refers to simulation models and scripts 1

<Project Directory>

<your_ip>_bb.v - Verilog HDL black box EDA synthesis file
<your_ip>_inst.v or .vhd - Sample instantiation template

synthesis - IP synthesis files

<your_ip>.qip - Lists files for synthesis

testbench - Simulation testbench files 1

<testbench_hdl_files>

<simulator_vendor> - Testbench for supported simulators

<simulation_testbench_files>

<your_ip>.v or .vhd - Top-level IP variation synthesis file

simulation - IP simulation files
<your_ip>.sip - NativeLink simulation integration file

<simulator vendor> - Simulator setup scripts
<simulator_setup_scripts>

<your_ip> - IP core variation files

<your_ip>.qip or .qsys - System or IP integration file

<your_ip>_generation.rpt - IP generation report

<your_ip>.bsf - Block symbol schematic file
<your_ip>.ppf - XML I/O pin information file
<your_ip>.spd - Combines individual simulation startup scripts 1

<your_ip>.html - Contains memory map

<your_ip>.sopcinfo - Software tool-chain integration file

<your_ip>_syn.v or .vhd - Timing & resource estimation netlist 1

<your_ip>.debuginfo - Lists files for synthesis

<your_ip>.v, .vhd, .vo, .vho - HDL or IPFS models2

<your_ip>_tb - Testbench for supported simulators
<your_ip>_tb.v or .vhd - Top-level HDL testbench file

Notes:
1. If supported and enabled for your IP variation
2. If functional simulation models are generated
3. Ignore this directory
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To manually add an IP variation to a Quartus II project, clickProject >Add/Remove Files in Project
and add only the IP variation .qip or .qsys file, but not both, to the project. Do not manually add the
top-level HDL file to the project.

Note:

Generating a Qsys System or IP Variation with qsys-generate
You can use the qsys-generate utility to generate RTL for yourQsys system, IP core variation, or simulation
models and scripts. You can create testbench systems for testing your Qsys system in a simulator using bus
functionalmodels (BFMs). Output from the qsys-generate command is the same as when generating using
the Qsys GUI.

Table 4: qsys-generate Command-Line Options

DescriptionUsageOption

The name of the .qsys system file to generate.Required<1st arg file>

Creates synthesis HDL files that Qsys uses
to compile the system in aQuartus II project.
You must specify the preferred generation
language for the top-level RTL file for the
generated Qsys system.

Optional--synthesis=<VERILOG|VHDL>

Creates a Block Symbol File (.bsf) for the
Qsys system.

Optional--block-symbol-file

Creates a simulation model for the Qsys
system. The simulation model contains
generated HDL files for the simulator, and
may include simulation-only features. You
must specify the preferred simulation
language.

Optional--simulation=<VERILOG|VHDL>

Creates a testbench system that instantiates
the original system, adding bus functional
models (BFMs) to drive the top-level
interfaces. When you generate the system,
the BFMs interact with the system in the
simulator.

Optional--testbench=<SIMPLE|STANDARD>

After you create the testbench system, you
can create a simulation model for the
testbench system.

Optional--testbench-simulation=<VERILOG|VHDL>

If you omit this command, Qsys uses a
standard default path. If you provide this
command,Qsys searches a comma-separated
list of paths. To include the standard path in
your replacement, use "$", for example, "/
extra/dir,$".

Optional--search-path=<value>
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DescriptionUsageOption

The maximum memory size that Qsys uses
for allocations when running qsys-
generate. You specify the value as <size>
<unit>, where unit is m (or M) for
multiples of megabytes or g (or G) for
multiples of gigabytes. The default value is
512m.

Optional--jvm-max-heap-size=<value>

Specifies the device family.Optional--family=<value>

Specifies the device part number. If set, this
option overrides the --family option.

Optional--part=<value>

Enables a mixed language simulation model
generation. If true, if a preferred simulation
language is set, Qsys uses a fileset of the
component for the simulation model
generation.When false, which is the default,
Qsys uses the language specified with --

file-set=<value> for all components for
simulation model generation.

Optional--allow-mixed-language-simulation

Modifying an IP Variation
You can easily modify the parameters of any Altera IP core variation in the parameter editor to match your
design requirements. Use any of the following methods to modify an IP variation in the parameter editor.

Table 5: Modifying an IP Variation

ActionMenu Command

Select the top-levelHDL (.v, or .vhd) IP variation file to launch
the parameter editor andmodify the IP variation. Regenerate
the IP variation to implement your changes.

File > Open

Double-click the IP variation to launch the parameter editor
and modify the IP variation. Regenerate the IP variation to
implement your changes.

View > Utility Windows > Project
Navigator > IP Components

Select the IP variation and clickUpgrade in Editor to launch
the parameter editor andmodify the IP variation. Regenerate
the IP variation to implement your changes.

Project > Upgrade IP Components
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Upgrading IP Cores
IP core variants generated with a previous version of the Quartus II software may require upgrading before
use in the current version of the Quartus II software. Click Project > Upgrade IP Components to identify
and upgrade IP core variants.

The Upgrade IP Components dialog box provides instructions when IP upgrade is required, optional, or
unsupported for specific IP cores in your design. You must upgrade IP cores that require it before you can
compile the IP variation in the current version of the Quartus II software. Many Altera IP cores support
automatic upgrade.

The upgrade process renames and preserves the existing variation file (.v, .sv, or .vhd) as <my_variant>_
BAK.v, .sv, .vhd in the project directory.

Table 6: IP Core Upgrade Status

Corrective ActionIP Core Status

You must upgrade the IP variation before compiling in the current version of
the Quartus II software.

Required Upgrade IP
Components

Upgrade is optional for this IP variation in the current version of the Quartus II
software. You can upgrade this IP variation to take advantage of the latest
development of this IP core. Alternatively you can retain previous IP core
characteristics by declining to upgrade.

Optional Upgrade IP
Components

Upgrade of the IP variation is not supported in the current version of theQuartus
II software due to IP core end of life or incompatibility with the current version
of the Quartus II software. You are prompted to replace the obsolete IP core with
a current equivalent IP core from the IP Catalog.

Upgrade Unsupported

Before you begin

• Archive the Quartus II project containing outdated IP cores in the original version of the Quartus II
software: Click Project > Archive Project to save the project in your previous version of the Quartus II
software. This archive preserves your original design source and project files.

• Restore the archived project in the latest version of the Quartus II software: Click Project > Restore
ArchivedProject. ClickOK if prompted to change to a supported device or overwrite the project database.
File paths in the archive must be relative to the project directory. File paths in the archive must reference
the IP variation .v or .vhd file or .qsys file (not the .qip file).

1. In the latest version of the Quartus II software, open the Quartus II project containing an outdated IP
core variation. The Upgrade IP Components dialog automatically displays the status of IP cores in your
project, along with instructions for upgrading each core. Click Project > Upgrade IP Components to
access this dialog box manually.

2. To simultaneously upgrade all IP cores that support automatic upgrade, click Perform Automatic
Upgrade. The Status andVersion columns updatewhen upgrade is complete. Example designs provided
with any Altera IP core regenerate automatically whenever you upgrade the IP core.
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Figure 9: Upgrading IP Cores

Displays upgrade
status for all IP cores
in the Project

Upgrades all IP core that support “Auto Upgrade”
Upgrades individual IP cores unsupported by “Auto Upgrade”

Checked IP cores
support “Auto Upgrade”

Successful
“Auto Upgrade”

Upgrade
unavailable

Double-click to
individually migrate

Example 1: Upgrading IP Cores at the Command Line

You can upgrade IP cores that support auto upgrade at the command line. IP cores that do not
support automatic upgrade do not support command line upgrade.

• To upgrade a single IP core that supports auto-upgrade, type the following command:

quartus_sh –ip_upgrade –variation_files <my_ip_filepath/my_ip>.<hdl>
<qii_project>

Example:
quartus_sh -ip_upgrade -variation_files mega/pll25.v hps_testx

• To simultaneously upgrade multiple IP cores that support auto-upgrade, type the following
command:

quartus_sh –ip_upgrade –variation_files “<my_ip_filepath/my_ip1>.<hdl>;  
<my_ip_filepath/my_ip2>.<hdl>”  <qii_project>

Example:
quartus_sh -ip_upgrade -variation_files "mega/pll_tx2.v;mega/pll3.v" hps_testx

IP cores older than Quartus II software version 12.0 do not support upgrade. Altera
verifies that the current version of the Quartus II software compiles the previous

Note:

version of each IP core. TheAltera IPReleaseNotes reports any verification exceptions
for Altera IP cores. Altera does not verify compilation for IP cores older than the
previous two releases.
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Related Information
Altera IP Release Notes

Migrating IP Cores to a Different Device
IP migration allows you to target the latest device families with IP originally generated for a different device.
Some Altera IP cores require individual migration to upgrade. The Upgrade IP Components dialog box
prompts you to double-click IP cores that require individual migration.

1. To display IP cores requiringmigration, clickProject >Upgrade IPComponents. TheDescription field
prompts you to double-click IP cores that require individual migration.

2. Double-click the IP core name, and then click OK after reading the information panel.
The parameter editor appears showing the original IP core parameters.

3. For the Currently selected device family, turn off Match project/default, and then select the new target
device family.

4. Click Finish, and then click Finish again to migrate the IP variation using best-effort mapping to new
parameters and settings. Click OK if you are prompted that the IP core is unsupported for the current
device. A new parameter editor opens displaying best-effort mapped parameters.

5. ClickGenerateHDL, and then confirm the Synthesis and Simulation file options. Verilog is the parameter
editor default HDL for synthesis files. If your original IP core was generated for VHDL, select VHDL to
retain the original output HDL format.

6. To regenerate the new IP variation for the new target device, clickGenerate.When generation is complete,
click Close.

7. Click Finish to complete migration of the IP core. Click OK if you are prompted to overwrite IP core
files. The Device Family column displays the migrated device support. The migration process replaces
<my_ip>.qip with the <my_ip>.qsys top-level IP file in your project.

Ifmigration does not replace<my_ip>.qip with<my_ip>.qsys, clickProject >Add/Remove Files
in Project to replace the file in your project.

Note:

8. Review the latest parameters in the parameter editor or generated HDL for correctness. IP migration
may change ports, parameters, or functionality of the IP core. During migration, the IP core's HDL
generates into a library that is different from the original output location of the IP core. Update any
assignments that reference outdated locations. If your upgraded IP core is represented by a symbol in a
supporting Block Design File schematic, replace the symbol with the newly generated <my_ip>.bsf after
migration.

The migration process may change the IP variation interface, parameters, and functionality. This
may require you to change your design or to re-parameterize your variant after the Upgrade IP

Note:

Components dialog box indicates that migration is complete. The Description field identifies IP
cores that require design or parameter changes.

Related Information
Altera IP Release Notes
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Simulating Altera IP Cores in other EDA Tools
The Quartus II software supports RTL and gate-level design simulation of Altera IP cores in supported EDA
simulators. Simulation involves setting up your simulator working environment, compiling simulation
model libraries, and running your simulation.

You can use the functional simulation model and the testbench or example design generated with your IP
core for simulation. The functional simulation model and testbench files are generated in a project
subdirectory. This directory may also include scripts to compile and run the testbench. For a complete list
of models or libraries required to simulate your IP core, refer to the scripts generated with the testbench.
You can use the Quartus II NativeLink feature to automatically generate simulation files and scripts.
NativeLink launches your preferred simulator from within the Quartus II software.

Figure 10: Simulation in Quartus II Design Flow
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Post-fit timing simulation is not supported for 28nmand later device archetectures. Altera IP supports
a variety of simulation models, including simulation-specific IP functional simulation models and

Note:

encrypted RTL models, and plain text RTL models. These are all cycle-accurate models. The models
support fast functional simulation of your IP core instance using industry-standardVHDLorVerilog
HDL simulators. For some cores, only the plain text RTL model is generated, and you can simulate
thatmodel. Use the simulationmodels only for simulation and not for synthesis or any other purposes.
Using these models for synthesis creates a nonfunctional design.

Related Information
Simulating Altera Designs

Introduction to Altera IP CoresAltera Corporation

Send Feedback

UG-01056
Simulating Altera IP Cores in other EDA Tools18 2014.08.18

http://www.altera.com/literature/hb/qts/qts_qii53025.pdf
mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20Introduction%20to%20Altera%20IP%20Cores%20(UG-01056%202014.08.18)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


Simulation Flows
The Quartus II software supports integration with EDA simulators.

Table 7: Simulation Flows

DescriptionSimulation
Flow

The NativeLink automated flow supports a variety of design flows. Do not use NativeLink if you
require direct control over every aspect of simulation.

• UseNativeLink to generate simulation scripts to compile your design and simulation libraries,
and to automatically launch your simulator.

• Specify your own compilation, elaboration, and simulation scripts for testbench and simulation
model files that have not been analyzed by the Quartus II software.

• Use NativeLink to supplement your scripts by automatically compiling design files, IP
simulation model files, and Altera simulation library models.

NativeLink
flow

Custom flows support manual control of all aspects of simulation, including the following:

• Manually compile and simulate testbench, design, IP, and simulation model libraries, or write
scripts to automate compilation and simulation in your simulator.

• Use the Simulation Library Compiler to compile simulation libraries for all Altera devices
and supported third-party simulators and languages.

Use the custom flow if you require any of the following:

• Custom compilation commands for design, IP, or simulation library model files (for
example, macros, debugging or optimization options, or other simulator-specific options)
.

• Multi-pass simulation flows.
• Flows that use dynamically generated simulation scripts.

Custom
flows

Altera supports specialized flows for various design variations, including the following:

• For simulation of Altera example designs, refer to the documentation for the example design
or to the IP core user guide.

• For simulation of Qsys designs, refer to Creating a System with Qsys.
• For simulation of designs that include the Nios II embedded processor, refer to Simulating

a Nios II Embedded Processor.

Specialized
flows

Related Information

• IP User Guide Documentation

• Creating a System with Qsys

• Simulating a Nios II Embedded Processor

Simulator Support
The Quartus II software supports specific EDA simulator versions for RTL and gate-level simulation.
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Table 8: Supported Simulators

PlatformVersionSimulatorVendor

Windows9.3Active-HDLAldec

Windows, Linux2013.10Riviera-PROAldec

Linux13.1Incisive EnterpriseCadence

Windows, Linux10.1eModelSim-Altera (provided)Mentor Graphics

Windows10.1eModelSim PEMentor Graphics

Windows, Linux10.2cModelSim SEMentor Graphics

Windows, Linux10.2cQuestaSimMentor Graphics

Linux2013.06-sp1VCS/VCS MXSynopsys

Simulation Levels
The Quartus II software supports various levels of simulation in supported EDA simulators.

Table 9: Supported Simulation Levels

Simulation InputDescriptionSimulation Level

• Design source/testbench
• Altera simulation libraries
• Altera IP plain text or IEEE encrypted

RTL models
• IP simulation models
• Altera IP functional simulation models
• Altera IP bus functional models
• Qsys-generated models
• Verification IP

Cycle-accurate simulation usingVerilogHDL,
SystemVerilog, andVHDLdesign source code
with simulation models provided by Altera
and other IP providers.

RTL

• Testbench
• Altera simulation libraries
• Post-synthesis or post-fit functional

netlist
• Altera IP bus functional models

Simulation using a post-synthesis or post-fit
functional netlist testing the post-synthesis
functional netlist, or post-fit functional netlist.

Gate-level
functional

• Testbench
• Altera simulation libraries
• Post-fit timing netlist
• Post-fit StandardDelayOutput File (.sdo)

Simulation using a post-fit timing netlist,
testing functional and timing. Not supported
for Arria V, Cyclone V, or Stratix V devices.

Gate-level
timing

Gate-level timing simulation of an entire design can be slow and should be avoided. Gate-level timing
simulation is not supported for Arria

®
V, Cyclone

®
V, or Stratix

®
V devices. Use TimeQuest static

timing analysis rather than gate-level timing simulation.

Note:
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HDL Support
The Quartus II software provides the following HDL support for EDA simulators.

Table 10: HDL Support

DescriptionLanguage

• For VHDL RTL simulation, compile design files directly in your simulator. To use
NativeLink automation, analyze and elaborate your design in theQuartus II software,
and then use the NativeLink simulator scripts to compile the design files in your
simulator. You must also compile simulation models from the Altera simulation
libraries and simulation models for the IP cores in your design. Use the Simulation
Library Compiler or NativeLink to compile simulation models.

• For gate-level simulation, the EDA Netlist Writer generates a synthesized design
netlist VHDL Output File (.vho). Compile the .vho in your simulator. You may also
need to compile models from the Altera simulation libraries.

• IEEE 1364-2005 encryptedVerilogHDL simulationmodels are encrypted separately
for each Altera-supported simulation vendor. If you want to simulate the model in
a VHDL design, you need either a simulator that is capable of VHDL/Verilog HDL
co-simulation, or any Mentor Graphics single language VHDL simulator.

VHDL

• For RTL simulation in Verilog HDL or SystemVerilog, compile your design files in
your simulator. To use NativeLink automation, analyze and elaborate your design
in theQuartus II software, and then use theNativeLink simulator scripts to compile
your design files in your simulator. You must also compile simulation models from
theAltera simulation libraries and simulationmodels for the IP cores in your design.
Use the Simulation Library Compiler or NativeLink to compile simulation models.

• For gate-level simulation, the EDA Netlist Writer generates a synthesized design
netlist Verilog Output File (.vo). Compile the .vo in your simulator.

Verilog HDL

SystemVerilog

• If your design is a mix of VHDL, Verilog HDL, and SystemVerilog files, you must
use a mixed language simulator. Since Altera supports both languages, choose the
most convenient language for any Altera IP core in your design.

• Altera provides Arria V, Cyclone V, Stratix V, and newer simulation model libraries
and IP simulation models in Verilog HDL and IEEE encrypted Verilog. Your
simulator's co-simulation capabilities support VHDL simulation of these models
using VHDL “wrapper” files. Altera provides the wrapper for Verilog models to
instantiate these models directly from your VHDL design.

Mixed HDL

You must convert schematics to HDL format before simulation. You can use the
converted VHDL or Verilog HDL files for RTL simulation.

Schematic

Compiling Simulation Models
The Quartus II software includes simulation models for Altera IP cores.

These models include IP functional simulation models, and device family-specific models in the <Quartus
II installation path>/eda/sim_lib directory. These models include IEEE encrypted Verilog HDL models for
both Verilog HDL and VHDL simulation. Before running simulation, you must compile the appropriate
simulation models from the Altera simulation libraries.
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Use any of the following methods to compile Altera simulation models:

• Use the NativeLink feature to automatically compile your design, Altera IP, simulation model libraries,
and testbench.

• Run the Simulation Library Compiler to compile all RTL and gate-level simulation model libraries for
your device, simulator, and design language.

• Compile Altera simulation models manually with your simulator.

After you compile the simulation model libraries, you can reuse these libraries in subsequent simulations
to avoid having to compile them again.

The specified timescale precision must be within 1ps when using Altera simulation models.Note:

Related Information
Altera Simulation Models

Generating IP Simulation Files for RTL Simulation
The Quartus II software supports both Verilog HDL and VHDL simulation of encrypted and unencrypted
Altera IP cores. If your design includes Altera IP cores, you must compile any corresponding IP simulation
models in your simulator with the rest of your design and testbench. The Quartus II software generates and
copies the simulation models for IP cores to your project directory.

You can use the following files to simulate your Altera IP variation.

Table 11: Altera IP Simulation Files

File NameDescriptionFile Type

Cadence

• cds.lib

• ncsim_setup.sh

• hdl.var

Mentor Graphics

• msim_setup.tcl

Synopsys

• synopsys_sim.setup
• vcs_setup.sh

• vcsmx_setup.sh

Aldec

• rivierapro_setup.tcl

Simulator-specific script to compile, elaborate,
and simulate Altera IP models and simulation
model library files. Copy the commands into
your simulation script, or edit these files to
compile, elaborate, and simulate your design
and testbench.

Simulator
setup script

<design name>.sipContains IP core simulation library mapping
information. The.sip files enable NativeLink
simulation and the Quartus II Archiver for IP
cores.

Quartus II
Simulation IP
File (.sip)
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File NameDescriptionFile Type

<my_ip>.vho

<my_ip>.vo

IP functional simulation models are cycle-
accurate VHDL or Verilog HDL models
generated by the Quartus II software for some
Altera IP cores. IP functional simulation
models support fast functional simulation of
IP using industry-standardVHDL andVerilog
HDL simulators.

IP functional
simulation
models

<my_ip>.vArria V, Cyclone V, Stratix V, and newer
simulation model libraries and IP simulation
models are provided inVerilogHDL and IEEE
encrypted Verilog HDL. VHDL simulation of
these models is supported using your
simulator's co-simulation capabilities. IEEE
encryptedVerilogHDLmodels are significantly
faster than IP functional simulation models.

IEEE
encrypted
models

Generating IP Functional Simulation Models for RTL Simulation
Altera provides IP functional simulationmodels for someAltera IP cores. To generate IP functional simulation
models, follow these steps:

• Turn on the Generate Simulation Model option when parameterizing the IP core.
• When you simulate your design, compile only the .vo or .vho for these IP cores in your simulator. In this

case you should not compile the corresponding HDL file. The encrypted HDL file supports synthesis by
only the Quartus II software.

Altera IP cores that do not require IP functional simulation models for simulation, do not provide
the Generate Simulation Model option in the IP core parameter editor.

Note:

Many recently released Altera IP cores support RTL simulation using IEEE Verilog HDL encryption.
IEEE encryptedmodels are significantly faster than IP functional simulationmodels. You can simulate
the models in both Verilog HDL and VHDL designs.

Note:

Related Information
AN 343: OpenCore Evaluation of AMPP Megafunctions

Generating Simulation Scripts
You can automatically generate simulation scripts to set up supported simulators. These scripts compile the
required device libraries and system design files in the correct order, and then elaborate or load the top-level
design for simulation. You can also use scripts to modify the top-level simulation environment, independent
of IP simulation files that are replaced during regeneration. You can modify the scripts to set up supported
simulators.

Use the NativeLink feature to generate simulation scripts to automate simulation steps. You can reuse these
generated files and simulation scripts in a custom simulation flow. NativeLink optionally generates scripts
for your simulator in the project subdirectory.

1. Click Assignments > Settings.
2. Under EDA Tool Settings, click Simulation.
3. Select the Tool name of your simulator.
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4. Click More NativeLink Settings.
5. Turn on Generate third-party EDA tool command scripts without running the EDA tool.

Table 12: NativeLink Generated Scripts for RTL Simulation

UseSimulation FileSimulator(s)

Source directly with your simulator./simulation/modelsim/<my_ip>.doMentor Graphics
ModelSim
QuestaSim

Source directly with your simulator./simulation/modelsim/<my_ip>.doAldec Riviera Pro

Add your testbench file name to this options file
to pass the file to VCS using the -file option. If
you specify a testbench file to NativeLink,
NativeLink generates an .sh script that runs VCS.

/simulation/modelsim/<revision name>
_<rtl or gate>.vcs

Synopsys VCS

Run this script at the command line using the
command: quartus_sh -t <script>

Any testbench you specify with NativeLink is
included in this script.

/simulation/scsim/<revision name>_
vcsmx_<rtl or gate>_<verilog or vhdl>
.tcl

Synopsys VCS MX

Run this script at the command line using the
command: quartus_sh -t <script>.

Any testbench you specify with NativeLink is
included in this script.

/simulation/ncsim/<revision name>_
ncsim_<rtl or gate>_<verilog or vhdl>
.tcl

Cadence Incisive
(NC SIM)

You can use the following script variables:

• TOP_LEVEL_NAME—The top-level entity of your simulation is often a testbench that instantiates your
design, and then your design instantiates IP cores and/orQsys systems. Set the value of TOP_LEVEL_NAME
to the top-level entity.

• QSYS_SIMDIR—Specifies the top-level directory containing the simulation files.
• Other variables control the compilation, elaboration, and simulation process.

Generating Custom Simulation Scripts with ip-make-simscript
Use the ip-make-simscript utility to generate simulation command scripts for multiple IP cores or Qsys
systems. Specify all Simulation Package Descriptor files (.spd), each of which lists the required simulation
files for the corresponding IP core or Qsys system. The IP parameter editor generates the .spd files.

ip-make-simscript compiles IP simulation models into various simulation libraries. Use the compile-to-
work option to compile all simulation files into a single work library. Use this option only if you require a
simplified library structure.

When you specify multiple .spd files, the ip-make-simscript utility generates a single simulation script
containing all required simulation information. The default value of TOP_LEVEL_NAME is the TOP_LEVEL_NAME
defined in the IP core or Qsys .spd file.

Set appropriate variables in the script, or edit the variable assignment directly in the script. If the simulation
script is a Tcl file that is sourced in the simulator, set the variables before sourcing the script. If the simulation
script is a shell script, pass in the variables as command-line arguments to the shell script.
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• To run ip-make-simscript, type the following at the command prompt:

<Quartus II installation path>\quartus\sopc_builder\bin\ip-make-simscript 

Table 13: ip-make-simscript Examples

StatusDescriptionOption

RequiredDescribes the list of compiled files andmemory
model hierarchy. If your design includes
multiple IP cores or Qsys systems that include
.spd files, use this option for each file. For
example:

ip-make-simscript --spd=ip1.spd --

spd=ip2.spd

--spd=<file>

OptionalSpecifies the location of output files. If
unspecified, the default setting is the directory
from which ip-make-simscript is run.

--output-directory=<directory>

OptionalCompiles all design files to the default work
library. Use this option only if you encounter
problems managing your simulation with
multiple libraries.

--compile-to-work

OptionalUses relative paths whenever possible.--use-relative-paths

Related Information

• Aldec Active-HDL and Riviera-PRO Support

• Synopsys VCS and VCS MX Support

• Mentor Graphics ModelSim and QuestaSim Support

Synthesizing Altera IP Cores in Other EDA Tools
You can use supported EDA tools to synthesize a design that includes Altera IP cores. When you generate
the IP core synthesis files for use with third-party EDA synthesis tools, you can optionally create an area
and timing estimation netlist. To enable generation, turn on Create timing and resource estimates for
third-party EDA synthesis tools when customizing your IP variation.

The area and timing estimation netlist describes the IP core connectivity and architecture, but does not
include details about the true functionality. This information enables certain third-party synthesis tools to
better report area and timing estimates. In addition, synthesis tools can use the timing information to achieve
timing-driven optimizations and improve the quality of results.

The Quartus II software generates the <variant name>_syn.v netlist file in Verilog HDL format regardless of
the output file format you specify. If you use this netlist for synthesis, you must include the IP core wrapper
file <variant name>.v or <variant name>.vhd in your Quartus II project.
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Related Information
Quartus II Integrated Synthesis

Instantiating IP Cores in HDL
You can instantiate an IP core directly in your HDL code by calling the IP core name and declaring its
parameters, in the same manner as any other module, component, or subdesign. When instantiating an IP
core in VHDL, you must include the associated libraries.

Accessing HDL Code Templates
The Quartus II software includes code examples or templates for inferred RAMs, ROMs, shift registers,
arithmetic functions, and DSP functions optimized for Altera devices. To access HDL code templates to
define these IP cores in HDL, follow these steps:

1. Open a file in the text editor.
2. Click Edit > Insert template.
3. In the Insert Template dialog box, click the + icon to expand either the Verilog HDL category or the

VHDL category, depending on the HDL you prefer.
4. Under Full Designs, expand the navigation tree to display the type of functions you want to infer.
5. Select the function to display the code in the Preview pane, and then click Insert.

Example Top-Level Verilog HDL Module
Verilog HDL ALTFP_MULT in Top-Level Module with One Input Connected to Multiplexer.

module MF_top (a, b, sel, datab, clock, result);
    input [31:0] a, b, datab;
    input clock, sel;
    output [31:0] result;
    wire [31:0] wire_dataa; 

    assign wire_dataa = (sel)? a : b;  
    altfp_mult inst1 (.dataa(wire_dataa), .datab(datab), .clock(clock), 
.result(result));

    defparam 
         inst1.pipeline = 11,
         inst1.width_exp = 8,
         inst1.width_man = 23,
         inst1.exception_handling = "no";    
endmodule

Example Top-Level VHDL Module
VHDL ALTFP_MULT in Top-Level Module with One Input Connected to Multiplexer.

library ieee;
use ieee.std_logic_1164.all; 
library altera_mf;
use altera_mf.altera_mf_components.all; 

entity MF_top is
     port (clock, sel  : in  std_logic;    
           a, b, datab : in  std_logic_vector(31 downto 0);   
           result      : out std_logic_vector(31 downto 0));
end entity;
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architecture arch_MF_top of MF_top is
signal wire_dataa : std_logic_vector(31 downto 0);
begin

wire_dataa <= a when (sel = '1') else b;

inst1 : altfp_mult 
     generic map (
             pipeline => 11,
             width_exp => 8,
             width_man => 23,  
             exception_handling => "no")  
     port map (
             dataa => wire_dataa,
             datab => datab,
             clock => clock,
             result => result); 
end arch_MF_top;

Document Revision History
This document has the following revision history.

ChangesVersionDate

• Added information about specifying parameters for IP cores
targeting Arria 10 devices.

• Added information about the latest IP output for Quartus II
version 14.0a10 targeting Arria 10 devices.

• Added information about individual migration of IP cores to the
latest devices.

• Added information about editing existing IP variations.

14.0a10.02014.08.18

• Changed title from Introduction toMegafunctions to Introduction
to Altera IP Cores.

• Increased scope of document to include updated information
about licensing, customizing, upgrading, and simulating all Altera
IP cores.

• Replaced MegaWizard Plug-In Manager with IP Catalog
information.

14.0.0June 2014

• Reorganization of content into topics.
• First tracking of changes in Document Revision History.

13.0 .1May 2013
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